The new forums

Posted by

New year and I knew you want some new news about new forums!  (That’s a lot of “new” 😀)

I’ll be the first to admit that there were some frustrations with our existing forum platform which didn’t help reinforce the strong community spirit that was always there on the forums over the years. For those that stuck with the forums, you have the gratitude of many of us here at Oracle. We took your feedback on board and took a fresh look at how to make the forums a good place to be, because providing a platform where people can easily share knowledge and help each other is critical to a good community.

One of the more common pieces of feedback we got was:

“Hey, if APEX is as cool as everyone says it is, why couldn’t you just build the forums in that?”

It’s pretty hard to argue with that logic…so we did!


It’s based on an internal app we use internally at Oracle for forum discussions, and so whilst it’s “battle hardened”, obviously the usage model and user experience (eg prioritising content, moderation etc) is slightly different in a fully public space, so we’ll be looking for any feedback you can have to make this a place you find it easy to interact with others and easily find solutions to your issues.

So please use the Feedback option to give us your thoughts, your ideas and your frustrations with the new forums.


It’s APEX, so it comes with all of the benefits of a low code environment to allow quick turnaround of enhancements and bug fixes. See you on the dev forum!


  1. Hi Connor,

    There are many years since I have not used the Oracle forums …
    I still remember however the good old days of Metalink, where finding anything was extremely easy,
    in spite of the “less bells and whistles” in the user interface.

    For the moment, I just wanted to check whether the forum is accessible to anyone with an Oracle account,
    or just to those with an Oracle support license.
    But, currently pressing the SignIn just redisplays the same page.

    I mentioned accessibility because , as a usual follower of Jonathan Lewis’s blog, there are cases in which he answers a question raised on an Oracle Forum, but specifies that a privilege is required for accessing the original forum page.
    So, it is not entirely clear to me how many forums exist at Oracle and whether any of them requires additional privileges than simply having an Oracle account.

    I hope indeed that, as you say, the community spirit will continue to dominate the entire activity,
    as it always did.

    Cheers & Best Regards,
    Iudith Mentzel

    1. I am unable to login to the new forum. Clicking on “Sign In” on the top right does nothing. I tried Chrome and Edge.

      I have popups enabled but that didn’t help either.

        1. Thanks for the tip, Connor. I see this error when I click on “Sign In”

          VM107:1 Uncaught TypeError: apexds.loginSamePage is not a function
          at :1:8
          (anonymous) @ VM107:1

        2. Hey Connor! I also was struggling in the last couple of days not being able to connect properly and subscribe to the new forum.

          I use Safari and Chrome on MacOS without much success. Here what I got from the JavaScript console for errors. Maybe it is the same as previously indicated by the other reader.
          [Error] FetchEvent.respondWith received an error: Load failed
          [Error] Cannot load .
          [Error] Failed to load resource: FetchEvent.respondWith received an error: Load failed

          A page or script is accessing at least one of navigator.userAgent, navigator.appVersion, and navigator.platform. Starting in Chrome 101, the amount of information available in the User Agent string will be reduced.
          To fix this issue, replace the usage of navigator.userAgent, navigator.appVersion, and navigator.platform with feature detection, progressive enhancement, or migrate to navigator.userAgentData.

        3. Hi Connor, Thank you for the patch! Unfortunately, I have the same error and I cannot participate in the forums.

          Is there an email address where I can reach support for help with this issue?


Got some thoughts? Leave a comment

Fill in your details below or click an icon to log in: Logo

You are commenting using your account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.